Categorías
Drupal Symfony

Drupal 10 finalmente necesitará al menos PHP 8.1

Hace un tiempo os contamos que Drupal 10 contaría con PHP 8 como requisito mínimo, pero que tampoco se descartaba que ese requisito se modificara al alza. Pues este ha sido el caso, se ha confirmado que Drupal 10 necesitará al menos un servidor que funcione como mínimo con la versión 8.1 de dicho lenguaje de programación.

¿Qué le pasa a tu negocio digital?

¿No creces a buen ritmo en audiencia o ventas? ¿No estás contento con tu CMS? ¿A Google no le a acabas de convencer?

En mejorCMS comos expertos. Consigue ayuda:

Contacta sin compromiso y te llamamos gratis

La razón es tan simple como que Symfony 6, que está detrás de muchos componentes de Drupal, ha decidido eso mismo y por lo tanto afecta a Drupal. Symfony lo ha explicado bien en un reciente artículo: Consideran que es la única opción viable para el proyecto y sostenible en el tiempo.  

🚨 ¿Sabías que aquí elaboramos la MEJOR NEWSLETTER de CMS?

Recibe cada semana de los mejores contenidos sobre CMS, trucos SEO, aumento de audiencia y mucho más:

¡Inscríbete ahora! ¡La newsletter no será gratis para siempre! Y cancela cuando quieras 🙂

Según datos de Packagist recogidos por Fabien Potencier, más del 70% de las instalaciones de su framework bundle usan PHP 8.1 y esa cifra está creciendo día a día, pero no está disponible para todos, lo cual es un problema y seguramente no permitirá actualizar en algunos casos.

Realizada la elección de versión de PHP, el equipo de Drupal puede ya revelar la fecha de lanzamiento de Drupal 10, que en estos momentos es agosto de 2022.

Sabiendo esto, si es necesario, es el momento de presionar a las empresas que proveen servicios de hosting que no dispongan de PHP 8.1 en su configuración. El equipo de Drupal se ha currado algunos mensajes en este artículo, aunque están en inglés.

Artículos relacionados:

Deja una respuesta

Tu dirección de correo electrónico no será publicada.